Recently switched to xenforo for this site

andrew3d

Aspirant
Joined
Mar 2, 2013
Messages
34
If you take a look at it, please provide constructive criticisms if you have any.
The site is for rabbit hunters, hunting with beagles, and beagles.
The forum was once fairly busy on other software, but since converting, it is now practically dead.
I converted from websitetoolbox to MYBB, then after a few weeks, to xenforo. Thanks.
www.straightupthemiddle.com

 

Matthew S

Adherent
Joined
Jun 27, 2015
Messages
298
Really brief look: Pixel Exit style looks great. Are you sure the redirect isn't causing people issues? Did you have some mobile app before that you don't have now? Did the double migration simply tick people off?
 

cellarius

Aspirant
Joined
Sep 6, 2017
Messages
30
Do you have proper redirects in place, i.e. not only for the homepage/domain, but for forums and threads at least? If not, you'll lose any incoming traffic from Google and other search engines until they have reindexed. This may take some time, especially if you did change your URL structure twice in short time with no redirects.

Only googling for your forum name popped up this thread, for example:
http://www.straightupthemiddle.com/archive/index.php?thread-8635656.html

The link returns a 404 error. Every person doing the same will end seeing an error, and turn away. This tells me you have no redirection in place, which you really should have.
 

andrew3d

Aspirant
Joined
Mar 2, 2013
Messages
34
Do you have proper redirects in place, i.e. not only for the homepage/domain, but for forums and threads at least? If not, you'll lose any incoming traffic from Google and other search engines until they have reindexed. This may take some time, especially if you did change your URL structure twice in short time with no redirects.

Only googling for your forum name popped up this thread, for example:
http://www.straightupthemiddle.com/archive/index.php?thread-8635656.html

The link returns a 404 error. Every person doing the same will end seeing an error, and turn away. This tells me you have no redirection in place, which you really should have.

I did a search for how to do a redirect. Appears are several ways.
I don’t have access to the old host, so knowing that where do I do this redirect?
 

andrew3d

Aspirant
Joined
Mar 2, 2013
Messages
34
Really brief look: Pixel Exit style looks great. Are you sure the redirect isn't causing people issues? Did you have some mobile app before that you don't have now? Did the double migration simply tick people off?
Possibly, and not having a proper redirect may have done more damage.
 

cellarius

Aspirant
Joined
Sep 6, 2017
Messages
30
I did a search for how to do a redirect. Appears are several ways.
I don’t have access to the old host, so knowing that where do I do this redirect?
You need to figure out rewrite rules for htaccess, but given your old installation is probably gone and ids may not have been preserved, it may be too late. You're suffering for not having planned your migration properly.

So.... what was the compelling reason for the conversion?
Since he has already converted, that seems a rather moot point.

Only thing to do (if getting proper redirection in place is not an option) is to sit and wait. Given time, Google will reindex the forum, and people will come back.
 

andrew3d

Aspirant
Joined
Mar 2, 2013
Messages
34
So.... what was the compelling reason for the conversion?
Websitetoolbox was expensive, and inflexible. I didn't start the site, but I inherited it.
I converted to MYBB because I was familiar with the database structures, but
I was most familiar with xenforo from an operational standpoint since I have used it for some time on my other forum.
 

Optic

Enthusiast
Joined
Mar 31, 2013
Messages
183
andrew3d - what Google has indexed for your website is a little messy:
https://www.google.com/search?q=site:http://www.straightupthemiddle.com

You have a mixture of Websitetoolbox, MyBB and XenForo URLs..

Even messier is your XenForo conversion is in a folder called /2018forum/

Adding redirects now is probably too late (may not be worth the extra effort), but you can clean things up by ensuring your XenForo forum is in the root folder (get rid of the /2018forum/ structure) i.e. make it so visiting http://www.straightupthemiddle.com will open the XenForo forum directly (get rid of the redirect)

Then add and verify your site in Google Search Console, then submit your XenForo XML sitemap - that will be the fastest way to get Google to index your XenForo forum URLs.

Also you really need to look into implementing HTTPs SSL on your forum, Chrome and Firefox started adding "Not Secure" warnings to login pages without HTTPs now. You'll get a small boost for fixing that..
 
Top