Problems with Apple News Plugin

  • Thread starter
  • Moderator
  • #1

cheat_master30

Moderator
Joined
Jan 16, 2010
Messages
3,862
Recently, I installed a plugin on my site that lets me submit content to Apple News. It worked fine to begin with, with the plugin linking up to my Apple News Publisher account perfectly and all articles being available on the service within a few minutes or so.

But now it seems it's broke for some reason. Despite me entering the right API key, secret key and channel ID, it still tells me the data is incorrect and could not be submitted.

Here's the JSON data from the debug logs:

Code:
Array
(
    [headers] => Requests_Utility_CaseInsensitiveDictionary Object
        (
            [data:protected] => Array
                (
                    [www-authenticate] => HHMAC
                    [content-type] => application/json; charset=UTF-8
                    [content-length] => 39
                )

        )

    [body] => {"errors":[{"code":"WRONG_SIGNATURE"}]}
    [response] => Array
        (
            [code] => 401
            [message] => Unauthorized
        )

    [cookies] => Array
        (
        )

    [filename] =>
    [http_response] => WP_HTTP_Requests_Response Object
        (
            [response:protected] => Requests_Response Object
                (
                    [body] => {"errors":[{"code":"WRONG_SIGNATURE"}]}
                    [raw] => HTTP/1.1 401 Unauthorized
WWW-Authenticate: HHMAC
Content-Type: application/json; charset=UTF-8
Content-Length: 39

{"errors":[{"code":"WRONG_SIGNATURE"}]}
                    [headers] => Requests_Response_Headers Object
                        (
                            [data:protected] => Array
                                (
                                    [www-authenticate] => Array
                                        (
                                            [0] => HHMAC
                                        )

                                    [content-type] => Array
                                        (
                                            [0] => application/json; charset=UTF-8
                                        )

                                    [content-length] => Array
                                        (
                                            [0] => 39
                                        )

                                )

                        )

                    [status_code] => 401
                    [protocol_version] => 1.1
                    [success] =>
                    [redirects] => 0
                    [url] => https://u48r14.digitalhub.com/channels/d10596bb-2a89-4177-b007-a1cff2939447/articles
                    [history] => Array
                        (
                        )

                    [cookies] => Requests_Cookie_Jar Object
                        (
                            [cookies:protected] => Array
                                (
                                )

                        )

                )

            [filename:protected] =>
            [data] =>
            [headers] =>
            [status] =>
        )

)


Request Meta:

Array
(
    [data] => Array
        (
            [links] => Array
                (
                    [sections] => Array
                        (
                        )

                )

        )

)
So, does anyone know what's going wrong here? Because the plugin I'm using in this one:

https://wordpress.org/plugins/publish-to-apple-news/

Yet the author says he can't offer any more advice on this one. And hey, if anyone wants server access to try and look into it, that'd be good too, since I've got a lot of things going on at the moment and can't be debugging this as well as providing content, marketing, etc.

Any ideas?
 
Top