Just switched to Burning Board

surfingseacow

Aspirant
Joined
Dec 28, 2015
Messages
28
It promises not to be an easy road to change :)

So far struggling with a bunch of things, such as the parsing of smilies, figuring out how to get a quick reply field (like you guys have here) etc.

Going to look around and steal some ideas from other forums. I'm not tech savvy enough to create my own solutions :)

If anyone has some usefull hints and pointers, for example, really good plug-ins, mods etc. Feel free to share.
 

surfingseacow

Aspirant
Joined
Dec 28, 2015
Messages
28
I added quick reply the by adding Javascript to the footer code field in acp > options > general

Code:
<script>
    //<![CDATA[
    $(function () {
        $('#messageQuickReply').show().find('button[data-type="cancel"]').hide();
        $('.jsQuickReply').hide();
    });
    //]]>
</script>

It works, but not sure if that is the best way to do it.
 
Last edited:

Sherrie

Fan
Joined
Jun 8, 2013
Messages
888
It's pretty daunting in that the community is mostly German but it's good software and worth the challenge, good luck :)
 

Sherrie

Fan
Joined
Jun 8, 2013
Messages
888
For me, vBulletin 4.2. My forum was becoming unusable due to problems with the editor and double posting and vbulletin support didn't even answer my thread on their support forums. In my mind I was already moving to burning board anyway because I hated vB4 the longer I used it but I was hoping to wait until bb4.1 was released but the posting issues got so bad I made the switch early. It was worth the money spent unlike my upgrade to vb5 license!

In 2016 I believe there will be more updates to Woltlab with the integration of a CMS into their framework and maybe even bb 4.2 (I hope)

I did consider xenforo, originally when I was considering upgrading my vb3 forum but their forum and the absence of the developers at the time put me off. I considered it again when considering burning board but burning board appealed to me more so I took the risk.
 

surfingseacow

Aspirant
Joined
Dec 28, 2015
Messages
28
For me it was the fact that it's responsive, therefore reducing the need for tapatalk. I wanted a whole new site, and now it's going to be a wordpress with WBB integrated.
The German community causes some problems, since most English searhces don't get you the wanted results. But I believe I'll get there.
A friend helping me out speaks a little German, and I use Google translate to try to understand what they talk about.

vBulletin 4 was kinda bulky to modify. But Burningboard isn't easy either (at least to me it isn't).

The only thing I really miss is an extensive manual, their FAQ is very basic, and I basicly need to take it an extra step back, since I'm pretty clueless about it all.

Major issues I'm trying to solve are:
- Smilies not parsing due to lack of whitespace (I need them to parse without whitespace before and after)
- Fixing the old vBulletin attachments after importing. Now they just show as [ ATTACH=CONFIG ]XXXX[ / ATTACH ] (no spaces) with the attachment added under the post.

Minor issues are:

The lack of oversight in their plugin store. I want to know what I can find/buy that could/would be cool. You can't search something if you don't know it exists.

So anyone with some cool ideas, plugins etc. Feel free to share.

(Are we allowed to post threadsavers?)
 

surfingseacow

Aspirant
Joined
Dec 28, 2015
Messages
28
I found what needs to be done to fix the attachment issue.

all I need to do is remove the "=config" part of the old text and it's fixed. Going to look around for a "mass fix". Don't know nothing about databases, so let's hope I don't set the world on fire.
 

surfingseacow

Aspirant
Joined
Dec 28, 2015
Messages
28
I performed a sql query to replace all the [ attach=config ] by [ attach ] using

Code:
update wbb1_post set message = replace(message, '[ATTACH=CONFIG]', '[ATTACH]');


But although this worked, the [ attach=config ] 1234 [ /attach ] now has been preplaced with the link to the attachment, and not the picture itself.

Anyone has a solution for this?

If I edit + save the post (without changing something) it does fixes the issue.2d4527b156811547da8b76e81968d6d8.png
cbd43f046417e7c22d96dd67c38168fd.png
 

surfingseacow

Aspirant
Joined
Dec 28, 2015
Messages
28
All I had to do was rebuild "posts" in ACP > system > maintenance > rebuild data > rebuild posts.

Feel stupid now :) Nothing new.
 

surfingseacow

Aspirant
Joined
Dec 28, 2015
Messages
28
Did you find these manuals any help?

Yeah, but not too much. They're pretty basic OR they assume you have a lot of advanced knowledge.

A simple task such as changing the icons proves to be a lot of work, because I can't find where/how to change it fe.

vBulletin had extensive manuals on those subject iirc.
 

Sherrie

Fan
Joined
Jun 8, 2013
Messages
888
I think we are just spoilt from the old vbulletin manual back in the days of the older versions. I don't think anyone else does that now, I wish Woltlab would!
 

demon326

Enthusiast
Joined
Oct 27, 2014
Messages
123
First of all, welcome to the little English community of WoltLab!
Second of all: STOP doing all those hardcode kinda things like messing in the database, just don't do that! The same for the "quick reply' your used to, in Burning board its inline, when ever you click the reply button, the field opens..

As for a Manual; https://blog.woltlab.com/entry/62-manual-burning-board-4-0/ 4.1 has some more features, but overall its good to begin with.

As for plug-ins: Don't buy the 'SEO' addon, the author is a dick and does not care about the customer..(Won't update plugin, marked as 'not supported anymore' a few months later the same addon is back for the full price, no upgrade price..)

'Must have' plug-ins:
https://pluginstore.woltlab.com/file/2174-sitemaps/
https://pluginstore.woltlab.com/file/2074-uz-community-bot-2/
https://pluginstore.woltlab.com/file/2075-uz-community-bot-2-burning-board-integration/
https://pluginstore.woltlab.com/file/1584-modern-shoutbox/
https://pluginstore.woltlab.com/file/1625-package-extension-modern-shoutbox-wbb4/
https://pluginstore.woltlab.com/file/2145-opensearch/
Thread- and Postingtemplates, can't find the link at the moment

Also, you never have to upload new files for updates, just some mouse clicks and your done.


Enjoy your stay and if you have any questions, tag me and i'l try to help :)
 

surfingseacow

Aspirant
Joined
Dec 28, 2015
Messages
28
demon326 thanks! We don't really use a shoutbox at our forum. And having something in place that isn't used is bad advertisement it seems. Kinda gives off a vibe that the forum is dead :p
We do have a "chatter" thread every month that serves as a kinda delayed shoutbox. Might give it a go.

Is there a way to let people log in using their Facebook account?

I kinda feel ashamed, but I don't even know what the bot and opensearch are supposed to do. The bot screenshots are in German, and can't really make out what it is for.
 

surfingseacow

Aspirant
Joined
Dec 28, 2015
Messages
28
Major issues I'm trying to solve are:
- Smilies not parsing due to lack of whitespace (I need them to parse without whitespace before and after)

This is still one of the most crucial tasks I have to tackle. It's essential to my forum that I can add a list of smileys that should parse without whitespace before and/or after it. It's a total of 74 smilies. Still no idea how to start on this.

We were able to make it happen with vBulletin without it creating issues. So it's possible.
 

surfingseacow

Aspirant
Joined
Dec 28, 2015
Messages
28
Found this in wcf\lib\system\bbcode\messageparser.php

Code:
/**

    * Parses smiley codes.

    * 

    * @param    string        $text

    * @return    string        text

    */

    protected function parseSmilies($text, $enableHtml = false) {

        foreach ($this->smilies as $code => $html) {

            //$text = preg_replace('~(?<!&\w{2}|&\w{3}|&\w{4}|&\w{5}|&\w{6}|&#\d{2}|&#\d{3}|&#\d{4}|&#\d{5})'.preg_quote((!$enableHtml ? StringUtil::encodeHTML($code) : $code), '~').'(?![^<]*>)~', $html, $text);

            $text = preg_replace('~(?<=^|\s|<li>)'.preg_quote((!$enableHtml ? StringUtil::encodeHTML($code) : $code), '~').'(?=$|\s|</li>'.(!$enableHtml ? '|<br />' : '').')~', $html, $text);

        }

       

        return $text;

    }

Is this the piece of code that makes smilies parse? I'm just trying to understand how it works.
 

Rasty

Fan
Joined
Feb 16, 2014
Messages
803
demon326 thanks! We don't really use a shoutbox at our forum. And having something in place that isn't used is bad advertisement it seems. Kinda gives off a vibe that the forum is dead :p
We do have a "chatter" thread every month that serves as a kinda delayed shoutbox. Might give it a go.

Is there a way to let people log in using their Facebook account?

I kinda feel ashamed, but I don't even know what the bot and opensearch are supposed to do. The bot screenshots are in German, and can't really make out what it is for.

The bot automatically performs tasks such as birthday messages, upgrades user category based upon the number of points a user has.

Facebook login is also possible
ACP - Options>Users>Registration
 
Last edited:
Top