Can someone confirm that VB 3.8.9 will work with PHP 5.4?

SteveP

Aspirant
Joined
Jun 16, 2018
Messages
27
I'm moving to a new host that has PHP 5.4 as the lowest PHP version option.
I'm on PHP 5.3.6 so I cannot upgrade to VB 3.8.11 until I have moved to new host as it requires PHP 5.6

Guessing VB 3.8.9 will run on PHP 5.4 but hoping for confirmation on this.

Attached is the PHP and MYSQL requirements from the VB site. VbulletinPHPversionsSupported.JPG
 

LeadCrow

Apocalypse Admin
Joined
Jun 29, 2008
Messages
6,578
I doubt many are, unless they're hosting themselves or using services running ancient insecure software.
Any decent host should have a recent php7 branch available as the recommended stack you can seamlessly switch to if desired as as 5.4 and 5.6 are EOL.
 

SteveP

Aspirant
Joined
Jun 16, 2018
Messages
27
Understand all that. I am running my own server and painted myself into a corner by not keeping up on updates since I wanted to stay with VB3.x ....
I just need to use 5.4 as an interim ....so anyone who has run VB 3.8.9 on PHP 5.4 would be able to confirm it will work.

LeadCrow ...I changed the title question to make more sense. As you pointed out I doubt anyone else is currently running old VB and PHP 5.4 code.
 
Last edited:

HallofFamer

Habitué
Joined
Sep 6, 2010
Messages
1,332
Why are you using the lowest PHP version? This is a terrible practice, try using at least PHP 5.6 and even better PHP 7.1+. VB 3.8.11 works with PHP 5.6 so it should be easy for you.
 

SteveP

Aspirant
Joined
Jun 16, 2018
Messages
27
It is interim. I need to know my VB software will work before I purchase and migrate the websites to a new host. I am moving to PHP 7 one step at a time. Still, no answer to my question.

On my current server I cannot get to vb 3.8.11 due to low PHP version (5.3.6). So first I have to move with vb 3.8.9 knowing it will work on the new host, then I can upgrade and easily up the PHP version used. Again, one step at a time.

If vb 3.8.9 will run on PHP 5.4 or even better on PHP 5.6 please confirm. Thanks.
 

SteveP

Aspirant
Joined
Jun 16, 2018
Messages
27
I thought I'd get a quick answer here but when I didn't I asked VB support. Got a quick answer from them.

Here is what they said:
Hello.

Yes, vB3.8.9 will run on PHP5.4. it will run on MySQL 4.1.0+.

Best regards,
 

ehd

Aspirant
Joined
Mar 28, 2014
Messages
29
Vb 3.8.9 was released yesterday, so why bother?

You might have had some time to think about getting away from vb.
 
Last edited:

Paul M

Limeade Addict
Joined
Jun 26, 2006
Messages
3,938
If vb 3.8.9 will run on PHP 5.4 or even better on PHP 5.6 please confirm. Thanks.
The answer is in the screenshot you posted.

vBulletin 3.8.9 Requires PHP 5.3.0+
It will run on 5.4 [and as far as I remember, is ok on 5.6].
Its not in the PHP 7 supported list, so it wont play well on php 7.


Vb 3.8.9 was released yesterday, so why bother?
Huh ??
 
Top