Added An Embed Only Video Gallery

fixer

I'm In My Prime
Joined
Jan 28, 2010
Messages
2,062
videogallery.png

We have added a new site feature to allow members to embed videos in a gallery..
https://www.mymilitia.com/videos/

You can rate, react and comment on the videos

Site groups now have ability to add Video feature to their groups to go along with our other site features within the "clubs" like custom pages, chatrooms, calendars, link directories... just about everything you can do on our site there is a smaller personal version of it for all the groups to have for themselves.

We are asking all our units to create and post recruitment videos (many already have these) and we look forward to seeing what else the members will add to the gallery.
 

R0binHood

Habitué
Joined
Nov 23, 2011
Messages
1,369
It's the conversion from one encoded format to another and as far as I'm aware it's not supported by any of the major platforms.
It's supported by the media gallery in XF, just not on vids uploaded to posts.

Certain vids need to be transcoded in order to work properly, for example videos recorded on iOS devices in the HEVC format won't play properly if not converted first.
 

fixer

I'm In My Prime
Joined
Jan 28, 2010
Messages
2,062
I figure YouTube does all that work, I don’t want users uploading videos anyways, same a giphy I have to upload here on xf for them to show correctly but on Invision Community all I have to post is the share link.... even works in bulk mail
 

fixer

I'm In My Prime
Joined
Jan 28, 2010
Messages
2,062
The Invision Community “gallery app” does not support any video.
 

haqzore

Devotee
Joined
Dec 6, 2012
Messages
2,273
Personally, I don't want to host videos myself, so embedding is perfect.

The cost/benefit of the bandwidth and storage needed to provide a good experience hosting videos is a big reason Google is the only one doing it. It's just prohibitively expensive.

(yes, I know there are other players in the game, but none approaching the scale of googs)
 

DanielF

Aspirant
Joined
Jul 6, 2018
Messages
44
The Invision Community “gallery app” does not support any video.
That’s wrong. You can enable and upload videos to the gallery.
That said, I’m also in the boat of Admins ä which prefer that the visitors upload videos to Vimeo, YouTube etc... and that my own site only embeds them.
 

fixer

I'm In My Prime
Joined
Jan 28, 2010
Messages
2,062
That’s wrong. You can enable and upload videos to the gallery.
That said, I’m also in the boat of Admins ä which prefer that the visitors upload videos to Vimeo, YouTube etc... and that my own site only embeds them.
Show me
 

fixer

I'm In My Prime
Joined
Jan 28, 2010
Messages
2,062
Default IPS 4.x gallery installation: https://www.danielf.dev/gallery/ima...0190927145844-apple-geräte-4k-hevc-10-bitm4v/

All you have to do is to set the group permission...
View attachment 53394

Which btw, was also mention your recent video topic at the IPS community;)

Supported formats:[View attachment 53395
There are no settings in the admin cp that specify any sort of video functionality within the gallery app

the gallery app its self does not seem to adapt well to the fact that the “media” is a video

F74CCF58-D5C2-4B45-B904-99973E0CA42B.jpeg

it calls it new images, and has no video preview... which is a must

i am willing to bet all the “languages” within the gallery refer to “images” or “photos” as the system does not accommodate much flexibility

so you say the setting is on the user permissions, that appears to be more of a general setting as to rather they can upload videos on the forums .. no where does it specify that setting is for the gallery.. ill make sure i have that turned off, not only did i not know that was a thing i most definitely do not want anyone to use it ... ever not just in the galley but on the boards either
 
Last edited:

fixer

I'm In My Prime
Joined
Jan 28, 2010
Messages
2,062
the video DanielF posted works on safari on iMac Pro, iPad Pro and iPhone X
 

R0binHood

Habitué
Joined
Nov 23, 2011
Messages
1,369
Yeah, only Apple stuff unfortunately, because it uses Apple's HEVC compression codec. It needs transcoding to a more compatible format if all your users are to be able to play it, otherwise it just appears broken.
 

fixer

I'm In My Prime
Joined
Jan 28, 2010
Messages
2,062
Yeah, only Apple stuff unfortunately, because it uses Apple's HEVC compression codec. It needs transcoding to a more compatible format if all your users are to be able to play it.
Damn Right!
4F07668A-8DDB-4D9B-8D6D-F1532FF03396.gif
 

DanielF

Aspirant
Joined
Jul 6, 2018
Messages
44
S
Yeah, only Apple stuff unfortunately, because it uses Apple's HEVC compression codec. It needs transcoding to a more compatible format if all your users are to be able to play it, otherwise it just appears broken.
Sorry, my mistake. It was indeed just a quick and dirty spontaneous upload from my 3D printer without paying attention to the used format.
 
Top