3.8 - how long is it useful?

Finance

Participant
Joined
Jul 2, 2012
Messages
53
I have some pages with vbulletin 3.8 - but how long can I (realistically) have it, - regarding php and msql issues and such? 1 year? 2 years?

They are now even complaining at vbulletin.com that vb4 has not yet been updated to php 5.4.
 

Sufikation

Participant
Joined
Feb 13, 2012
Messages
85
This will be some good info to have seeing has how I am actually looking to buy a used vB 3.8...or 4 license. Might not be worth my time depending on what people have to say.
 

PoetJC

⚧ Jacquii: Kween of Hearts ⚧
Joined
Jul 9, 2006
Messages
21,033
I believe vB 3.8.x has EOLed...? There will be no further bug fixes - but there may be security patches released if need be.

I believe the vB community as a whole will support vB 3.8.x for a while yet. Don't quote me on that though ;)

HTH,

J.
 

Judge Dredd

Old Guy
Joined
Apr 20, 2011
Messages
3,144
This is really a tough question to answer. There's no telling what PHP plans to implement in future versions.

I've tested vB 3.8.7 up to PHP 5.3.19 and it works okay.
 

Iconic

Tazralian
Joined
Jan 25, 2010
Messages
773
You could probably have it as long as you want it. If you want it, just don't upgrade mysql or php. Other than that you could hire a coder to make it work with the newest mysql and php but that might be a bit of money.
 

BirdOPrey5

#Awesome
Joined
Aug 14, 2008
Messages
4,213
Realistically exploits aren't found in VB 3.x "everyday." It's been a LONG time a real exploit was found on 3.x- even the last couple of security fixes weren't all that dangerous. While it is possible a zero-day exploit is found on 3.8.7 at this point I'd say it's unlikely.

MySQL has continued working just fine through all the new versions. You may run into issues with PHP 5.4 on 3.x but your options are to get them fixed (someone may publish the fixes if they are really necessary) or get a package where you can keep whatever version of PHP you want.

I put a lot of time into getting my 3.x site ready to upgrade to 4.x but after looking at all the things I'd lose (mostly because of the AME mod which is excellent on 3.x but not as great on 4.x) I question again whether I will ever upgrade.
 

Gladius

Enthusiast
Joined
Dec 16, 2011
Messages
172
BirdOPrey5, any chance you'd want to put together a fix pack to get 3.8 working on latest PHP? This is going to become a necessity for many of us rather soon.
 

BirdOPrey5

#Awesome
Joined
Aug 14, 2008
Messages
4,213
BirdOPrey5, any chance you'd want to put together a fix pack to get 3.8 working on latest PHP? This is going to become a necessity for many of us rather soon.
When I get the time I do intend to look at it- if it's something I can fix I will release the "How To" on vBulletin.org and my own site... I don't imagine it will be very different from the fixes already provided by others for VB4 in JIRA but who knows.

Unfortunately can't commit to a timeline.
 

2dub

Adherent
Joined
Mar 10, 2010
Messages
370
Good info here as I have a 3.8 license I'm currently not using, but am thinking of a project for.
 

Gladius

Enthusiast
Joined
Dec 16, 2011
Messages
172
When I get the time I do intend to look at it- if it's something I can fix I will release the "How To" on vBulletin.org and my own site... I don't imagine it will be very different from the fixes already provided by others for VB4 in JIRA but who knows.

Unfortunately can't commit to a timeline.
Awesome, I'll be on the lookout for that, thanks!
 

vijayninel

Ave atque vale
Joined
Mar 29, 2010
Messages
914
When I get the time I do intend to look at it- if it's something I can fix I will release the "How To" on vBulletin.org and my own site.
This will be much appreciated by many of us. Please look into it whenever you can. :)

Unfortunately along with default vB 3 some of the mods which are no longer supported also dont work correctly with newer versions of PHP. I had a problem with GARS but fortunately I managed to fix it myself.
 

BirdOPrey5

#Awesome
Joined
Aug 14, 2008
Messages
4,213
For what it's worth I just did a quick install of 3.8.7 on Xampp with PHP 5.4.7. Despite a couple standards warnings it installed fine, and I was able to make posts and use the Admin CP with no visible errors.

Only thing I noticed broken was human verification/image verify and the same fix to class_image.php for VB 4.x worked to fix it in 3.8.7 as well.


I didn't use any advanced features but the basics work at least.
 

Gladius

Enthusiast
Joined
Dec 16, 2011
Messages
172
I think the biggest issue will be a huge number of errors and warnings in the logs (especially on large boards, this would be a big problem), plus I seem to remember reading about some other things not working properly.

Also, you should probably look at 5.5 too at this point already...
 

BirdOPrey5

#Awesome
Joined
Aug 14, 2008
Messages
4,213
The main thing with 5.5 will be making sure you are setup as mysqli as opposed to mysql in your config.php. You should be on that already but it will be required in PHP 5.5.
 

Judge Dredd

Old Guy
Joined
Apr 20, 2011
Messages
3,144
While we're talking about software with version 5.5, Joe, do you know if MySQL 5.5 works with 3.8.7?
 
Top