vBulletin Discuss vBulletin.

Reply
 
Thread Tools

  #1  
Old 03-07-2013, 01:10 PM
darnoldy's Avatar
darnoldy darnoldy is offline
Curmudgeon
 
Join Date: Dec 2004
Posts: 527
darnoldy is a name known to alldarnoldy is a name known to alldarnoldy is a name known to alldarnoldy is a name known to alldarnoldy is a name known to alldarnoldy is a name known to all
Default What Does EoL Really Mean?
Folks-

I assume that "End of Life" does not mean that all of the code and databases will suddenly cease to exist.

From another thread:
Quote:
Originally Posted by PoetJC View Post
I believe vB 3.8.x has EOLed...? There will be no further bug fixes - but there may be security patches released if need be.
That it? It might also mean that one can no longer get questions answered on the official support forum. I think I can live with that.

So, the question then becomes, will 3.8 continue to work with new versions of PHP & MySQL. So, here's what I've heard:

Quote:
Originally Posted by BirdOPrey5 View Post
You may run into issues with PHP 5.4 on 3.x but your options are to get them fixed (someone may publish the fixes if they are really necessary) or get a package where you can keep whatever version of PHP you want.
Quote:
Originally Posted by BirdOPrey5 View Post
For what it's worth I just did a quick install of 3.8.7 on Xampp with PHP 5.4.7. Despite a couple standards warnings it installed fine, and I was able to make posts and use the Admin CP with no visible errors.
Quote:
Originally Posted by Gladius View Post
I think the biggest issue will be a huge number of errors and warnings in the logs (especially on large boards, this would be a big problem)
Quote:
Originally Posted by BirdOPrey5 View Post
The main thing with 5.5 will be making sure you are setup as mysqli as opposed to mysql in your config.php. You should be on that already but it will be required in PHP 5.5.
Quote:
Originally Posted by Judge Dredd View Post
Joe, do you know if MySQL 5.5 works with 3.8.7?
Quote:
Originally Posted by Gladius View Post
I'm running it, so it should.
So, If I follow all of that, under PhP 5.4, vB 3.8 generated some error messages about "nonstandard code" that can be turned off, but it still works. And under PHP 5.5, you will be required to be using mysqli, but you should be doing that now anyway.

Yes, vB 3.8 is old; yes, the stock templates look a little tired; yes, some of you think IB is the spawn of satan and has destroyed the forum community; yes, I could buy newer and kewler software...none of those things are relevant to my question.

I have a 1968 VW bug. If I bought a newer car, I could get cup holders, a built-in DVD player, onStar, and a bunch of kewl stuff that I neither want nor need.—and, if I did want some of that stuff, I could get it as a thrid-party add-on. If I have to replace the transmission or rebuild the engine, I can do that—I don't have to replace the whole car.

I feel the same way about vB 3.8—it does all the things that I require of it, I just want to know how hard its going to be to keep it running.

--don
Reply With Quote
  #2  
Old 03-07-2013, 01:35 PM
LeadCrow's Avatar
LeadCrow LeadCrow is offline
Apocalypse Admin
 
Join Date: Jun 2008
Admin Experience: Advanced
Posts: 3,687
LeadCrow has a reputation beyond reputeLeadCrow has a reputation beyond reputeLeadCrow has a reputation beyond reputeLeadCrow has a reputation beyond reputeLeadCrow has a reputation beyond reputeLeadCrow has a reputation beyond reputeLeadCrow has a reputation beyond reputeLeadCrow has a reputation beyond reputeLeadCrow has a reputation beyond reputeLeadCrow has a reputation beyond reputeLeadCrow has a reputation beyond repute
Default
End Of Life means it's no longer viable to keep supporting. It doesnt necessarily mean its completely unsupported, just that general support has moved past that version and the first fix to any issue you face will be to upgrade to a more recent, supported version and see if your problem was fixed.
You could alternatively go with a 'management' company which can include support for vb versions obsoleted by vBS, if you dont wish to upgrade.

Getting back to the car analogy, manufacturers can EOL old car makes and no longer produce or store compatible parts, but garages specifically offering support for old makes or counting owners of those as a significant chunk of their customerbase can keep offering that support unofficially.
__________________
"It's better to be a lion for a day than a sheep all your life"
Reply With Quote
  #3  
Old 03-08-2013, 08:46 AM
BirdOPrey5's Avatar
BirdOPrey5 BirdOPrey5 is offline
#Awesome
 
Real Name: Joe
Join Date: Aug 2008
Admin Experience: Advanced
Location: New York
Posts: 838
BirdOPrey5 is a splendid one to beholdBirdOPrey5 is a splendid one to beholdBirdOPrey5 is a splendid one to beholdBirdOPrey5 is a splendid one to beholdBirdOPrey5 is a splendid one to beholdBirdOPrey5 is a splendid one to beholdBirdOPrey5 is a splendid one to behold
Default
You can still get support for VB 3.x, both on the forums and in tickets as well.

EOL means no new features or bug fixes. Security patches are possible but only for 3.8.7.
Reply With Quote
  #4  
Old 03-09-2013, 12:34 PM
darnoldy's Avatar
darnoldy darnoldy is offline
Curmudgeon
 
Join Date: Dec 2004
Posts: 527
darnoldy is a name known to alldarnoldy is a name known to alldarnoldy is a name known to alldarnoldy is a name known to alldarnoldy is a name known to alldarnoldy is a name known to all
Default
Thanks, folks!

Seems like, I ought to be able to keep a vB 3.8 forum running for a couple more years, maybe longer (depending on what happens with PHP 5.5).

If I don't need any of the features that 4.X has that 3.8 doesn't, then there would be no advantage to converting to 4 at this point, because I'd still have the same issues and life-expectancy.

Do you concur?

--don
Reply With Quote
  #5  
Old 03-09-2013, 07:18 PM
Paul M's Avatar
Paul M Paul M is offline
Cable Forum Admin
 
Real Name: Paul ....
Join Date: Jun 2006
Admin Experience: Guru
Location: Nottingham, UK
Age: 51
Posts: 747
Paul M is a name known to allPaul M is a name known to allPaul M is a name known to allPaul M is a name known to allPaul M is a name known to all
Default
Quote:
Originally Posted by BirdOPrey5 View Post
Security patches are possible but only for 3.8.7.
In most cases it would not be hard to port such fixes back to older versions either. Somoene would almost certainly post details.
__________________
Anything posted here is my own view or opinion, and not that of any company I may work for (unless otherwise stated)
Reply With Quote
  #6  
Old 03-10-2013, 10:33 PM
RunCompanies's Avatar
RunCompanies RunCompanies is offline
TAZ Rookie
 
Join Date: Mar 2009
Posts: 9
RunCompanies will become famous soon enough
Default
Let's hope v3 will last for many, many more years to come..
Reply With Quote
Reply

  Admin Zone Forums > The Software Zone > Forum Software > vBulletin





Currently Active Users Viewing this Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


 

All times are GMT -4. The time now is 01:45 PM.


Powered by: vBulletin
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Page generated in 0.06147504 seconds with 14 queries
The Admin Zone © copyright 2003-2014 All Rights Reserved. Content published on The Admin Zone requires permission for reprint.